i am trying to create a remote server project on an iis 6.0 server that has only one IP. The development sites use hostheader names to connect and I am unable to define what the remote directory value should be.

The root URL works and shows the site but I can't get the remote directory specified. I have tried //servername/contentdir , //contentdir (that one says it cannot create a file when it already exist) / (gives the index outside of bounds array). But mainly I get file not found.

thanks

juanc says:

Are you using ftp to connect to the server? If so, make sure you can get to the directory you want from ftp.

ewg says:

I can connect via browser using "ftp://192.168.1.10/media" when I enter //192.168.1.10/media for the remote directory it says "remote server returned and error 404"

the files i want to use to create the project are at 192.168.1.10/media. The root url is dev.media.com.

No luck so far. I am not getting something!

juanc says:

Try this:

Remote url:

http://192.168.1.10/media

And the remote path:

/media

ewg says:

Thanks for the suggestion I tried it and get "/media: Cannot create a file when that file already exists. (550). It looks like progress :)

ewg says:

I have made some progress using filemon I see that after creating and deleting _vsphp_info.php file in the d:\media directory it tried to query for a php5 in the d:tmpFTP\folder which is the default ftp folder from which i have a virtual ftp dir pointing to d:\media.

Finaly VS2005 puts an error message at the bottom left of the main window that says "creating project 'myMedia'... project creation failed.

juanc says:

Sorry for all these issues. Try installing DbgView to get debug traces that can shed light on what the problem is. Run DbgView before you start the wizard.

Thanks

ewg says:

here is what DBGview shows

[4664] Executing ProjectFromRemoteServer wizard
[4664] Ready to show NewProjectFromRemoteServerWizard dialog
[4664] RemoteServices using FTP
[4664] Checking if directory exists: /media
[4664] Checking if directory exists: /media
[4664] Checking if directory exists: /php5/pear

Thats where it stops it is looking in the default FTP directory where the virtual directory is, not in the folder where the web site content is. I think it has something to do with hostmeader aliasing and using virtual FTP directory to that content. What do you suggest?

ewg says:

I changed to 2.4 and was able to create the project just fine